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Introduction 
he Code Module Library is a tool that can be used to organize snippets of 
code for future use. In addition to being able to become a repository for code, 
the Code Module Library also facilitates easier customization of code to make 
code more meaningful and in turn make the C Stamp an even more powerful 

learning experience. 

Notices 
CSTAMP™ and CSTAMP™ Related Hardware Products, Software 
Products and Documentation are developed and distributed by A-WIT 
Technologies, Inc. All rights reserved by A-WIT Technologies, Inc. A-WIT 
SOFTWARE OR FIRMWARE AND LITERATURE IS PROVIDED 
“AS IS,” WITHOUT WARRANTY OF ANY KIND, EXPRESS OR 
IMPLIED, INCLUDING BUT NOT LIMITED TO THE 
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A 
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO 
EVENT SHALL A-WIT BE LIABLE FOR ANY CLAIM, DAMAGES 
OR OTHER LIABILITY ARISING OUT OF OR IN CONNECTION 
WITH THE SOFTWARE OR FIRMWARE OR THE USE OF 
OTHER DEALINGS IN THE SOFTWARE OR FIRMWARE. 

MPLAB C-18 and MPLAB C-18 Users Guide is reproduced and 
distributed by A-WIT Technologies, Inc. under license from Microchip 
Technology Inc. All rights reserved by Microchip Technology Inc. 
MICROCHIP SOFTWARE OR FIRMWARE AND LITERATURE IS 
PROVIDED “AS IS,” WITHOUT WARRANTY OF ANY KIND, 
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO 
THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A 
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO 
EVENT SHALL MICROCHIP BE LIABLE FOR ANY CLAIM, 
DAMAGES OR OTHER LIABILITY ARISING OUT OF OR IN 
CONNECTION WITH THE SOFTWARE OR FIRMWARE OR THE 
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USE OF OTHER DEALINGS IN THE SOFTWARE OR 
FIRMWARE. 

Microchip CML and Microchip CML Users Guide is reproduced and 
distributed by A-WIT Technologies, Inc. under license from Microchip 
Technology Inc. All rights reserved by Microchip Technology Inc. 
MICROCHIP SOFTWARE OR FIRMWARE AND LITERATURE IS 
PROVIDED “AS IS,” WITHOUT WARRANTY OF ANY KIND, 
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO 
THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A 
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO 
EVENT SHALL MICROCHIP BE LIABLE FOR ANY CLAIM, 
DAMAGES OR OTHER LIABILITY ARISING OUT OF OR IN 
CONNECTION WITH THE SOFTWARE OR FIRMWARE OR THE 
USE OF OTHER DEALINGS IN THE SOFTWARE OR 
FIRMWARE. 

Getting Support 
If possible, please check the C Stamp website www.c-stamp.com under SUPPORT for 
any updates to documentation, changes, or notices that may have become available 
since your Installation CD was produced. If you continue to have any issues for which 
a solution is not found in the aforementioned website, please e-mail tech_support@a-
wit.com for help. 

Code Module Library Installation 
To install the CML the file “CML.exe” must be run. Upon running CML.exe a 
notification window might pop up that looks like the image below. 
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After clicking on Run, the CML Installation Wizard will begin to initialize. When the 
Installation Wizard has finished initializing, another window will appear like the image 
below. 
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Leaving the default directory as the directory where the CML will be installed, click 
OK. 

After selecting the CML installation directory, a license agreement will appear like in 
the image below. After reading it, click on OK. 

 

 

After clicking on OK you will be given a choice as to whether or not you will want to 
place a shortcut to the CML on your desktop. If you would like a CML shortcut to be 
placed on your desktop, type in Yes as shown in the image on the left. If you would 
not like a CML shortcut to be placed on your desktop, type in No as shown in the 
image on the right.  
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After deciding on whether or not you would like a CML shortcut on you desktop you 
will then have another choice as to whether or not you would like a start menu icon for 
the CML. If you would like a CML icon to be placed on your start menu, type in Yes 
as shown in the image on the left. If you would not like a CML icon to be placed on 
your start menu, type in No as shown in the image on the right. 

 

After all the previous steps have been completed the installation will have been 
completed successfully and you will see a window such as the one in the image below. 
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Installing the C Stamp Code Module Library Plugin 
After installing the Code Module Library, the next step is to install the C Stamp Code 
Module Library Plugin. The C Stamp Code Module Library Plugin links the CML to 
the A-WIT provided code snippets so that the user does not have to manually input 
them. 

To install the C Stamp Code Module Library Plugin, open the file 
CSTAMP_CML_Installer. Upon opening the CSTAMP_CML_Installer file, a window 
will appear like the one below. Click on Next to proceed with the installation of the C 
Stamp Code Module Library Plugin. 
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After beginning the installation of the C Stamp Code Module Library Plugin, you will 
be prompted with a license agreement. After reading the license agreement, click on “I 
agree with the above terms and conditions” and then click on next. 
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After agreeing to the terms and conditions of the license agreement, the installation 
window will look like the one below. Click Next to proceed with the installation 
process. Make sure that the default installation directory is used or the C Stamp Code 
Module Library Plugin may not work. 

 

 

After all the previous steps have been completed successfully, the C Stamp Code 
Module Library Plugin is now ready to be installed. Click on Start to begin the 
installation of the C Stamp Code Module Library Plugin. 



A - W I T  T E C H N O L O G I E S  I N C .  

 9 

 

 

After clicking Start, the C Stamp Code Module Library Plugin will be installed and you 
will be presented with the following window that notifies you of a successful 
installation of the C Stamp Code Module Library. 
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After the C Stamp Code Module Library Plugin has been successfully installed, click on 
Exit. 

The Code Module Library and all its necessary plugins have been installed successfully. 

Using the C Stamp Code Module Library 
The C Stamp Code Module Library has many features that make it an ideal solution for 
organizing snippets of code that can be used in the future. 

Below are the various parts of the Code Module Library Window. The five main parts 
are: 

Description – Here, there is an informative description of the snippet that you are 
currently viewing 

Snippet Tree – Here is the hierarchy of all the snippets. Both A-WIT provided 
snippets and user generated snippets will appear here. 

Snippet’s Text – Here, the code that makes up the snippet is displayed. 

Timestamp – Here, the time that the current snippet was last edited is displayed. 



A - W I T  T E C H N O L O G I E S  I N C .  

 11 

Variable Replacement List – Here, the variables in the snippet’s text are displayed 
and can be replaced here. 

 

 

Create a New Snippet 
To create a snippet, go to File->New... in the menu bar. Clicking New... will bring up 
the window shown below. When you are making a new snippet, you must make sure 
that the file that is being changed is user.snp. If user.snp is not being changed, your 
snippets might be erased when the A-WIT provided snapshot file is updated with 
more snippets. Using user.snp ensures that your snippets remain unchanged from 
future updates. 
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There are three key fields to be concerned with when creating a snippet. Where it 
will be placed on the tree is the Hierarchy field, its name, and the snippet's text at 
the bottom. All fields are detailed below. 

Once satisfied with what file the snippet will be located in, where in the tree it will 
be located, and the snippet information itself, hit OK, and the New Window will 
close, create your snippet, and show it in the Main Window. 

Filename Field 

At the top, the first grayed out box is the filename text box. This is the file where 
your snippet will be stored. If a snippet or directory was selected on the Snippet 
Tree of the main window when you opened the New Window, the New Window 
will automatically load the file associated with the selected item. This can help 
keep similar snippets together in files, but to change the file, select either of the 
Browse... or New... buttons. 

Hierarchy Field 



A - W I T  T E C H N O L O G I E S  I N C .  

 13 

This field specifies where in the Snippet Tree your snippet will be located. The 
Code Module Library tries to associate it where you would likely want it to go 
when you create a new snippet based on your selection in the Main Window. To 
change this, and to see a more user friendly appearance, select the Change button. 
Doing so brings up the following window. 

 

 

 

As seen above in, if the OK button is clicked, the new snippet would be located 
under the folder If Statements, which is located under ASM, which is on the root 
level. The text in the hierarchy field will appear as "ASM;If Statements". 

Name 

Your snippet needs a name. This text entry box is where to provide the name of 
your snippet. Snippets in the same folder may not have the same name. 

Description 

Lastly the description box accompanies the snippet as seen in the Main Window, 
and is present for a quick summary of what the snippet does or how to use it. 

Variables 
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Variables may be declared which when used on the main application window will 
be replaced with text the user types under Replace With. Type in labels which will 
need to be changed, and other variables. Even if the variable names do not need 
to be changed, listing them here will help identify what variables need to be 
declared in the user application. 

Text 

Here the text of the snippet should be typed. This text will be your code snippet, 
or other piece of text. 

Copy a Snippet 
Copying the snippet to the clipboard. 

First, a snippet item must be selected in the Snippet Tree. Snippet items display a 
notepad image to their left, and when selected will cause the description and text to 
appear on their respective displays of the main window. 

Hot-keys to Copy 

Once a snippet is selected, there are several ways to copy a snippet to provide 
convenience for many users. The three most common means to copy a snippet are 
provided by accessing Edit->Copy from the menu bar, hitting Ctrl+C, or clicking the 
Copy button on the right pane. 

In addition to these common ways of copying, you can also double-click a snippet to 
copy it, or hit enter twice while selected in the tree. 

Optional Step - Replace Variables 

A snippet may be used without replacing any words, but to quickly change instances of 
text under Variable, type beside it under Replace With. As shown here mulcnd and 
mulplr will be replaced with user application variables Sensor1Value and ScaleValue, 
while Prod_H will be left unchanged. 

 

 

Putting the snippet into your application. 
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Once the snippet is copied to the clipboard, it is as simple as pasting it into the code of 
your application. 

Have MPLAB open, or another editor you prefer, and paste the snippet where you 
want it to go in your editor. 

Edit a Snippet 
Editing a snippet is a very similar process to creating a new snippet. 

First, a snippet must be selected in the tree, and then click Edit->Edit Snippet, or use 
another means to bring up the Edit Window. 

The image below shows the Edit Window. It is styled just like the New Window, but it 
will replace the snippet you are editing instead of making a new one. 

 

 

From here, all the information that you want to edit can be edited here. 
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Terms and Conditions 
Quality Assurance 

A-WIT has stringent quality control procedures in place to insure the best quality 
products. 

90-Day Limited Warranty 

A-WIT Technologies, Inc warrants its products against defects in materials and 
workmanship for a period of 90 days. If you discover a defect, A-WIT Technologies, 
Inc. will, at its option, repair, replace, or refund the purchase price. After 90 days, 
products can still be sent in for repair or replacement, but there will be a $10.00USD 
minimum inspection/labor/repair fee (not including return shipping and handling 
charges). 

14-Day Money-Back Guarantee 

If, within 14 days of having received your product, you find that it does not suit your 
needs, you may return it for a refund. A-WIT will refund the purchase price of the 
product in the form of a check, excluding shipping/handling costs, once the product is 
received. This refund does not apply if the product has been altered or damaged. If you 
decide to return the products after the 14-day evaluation period, a 20% restocking fee 
will be charged against a credit. 

Disclaimer 

Warranty does not apply if the product has been altered, modified, or damaged. A-
WIT makes no other warranty of any kind, expressed or implied, including any 
warranty of merchantability, fitness of the product for any particular purpose even if 
that purpose is known to A-WIT, or any warranty relating to patents, trademarks, 
copyrights or other intellectual property. A-WIT shall not be liable for any injury, loss, 
damage, or loss of profits resulting from the handling or use of the product shipped.  

How to Return a Product 

When returning, you must first e-mail sales@a-wit.com for a Return Merchandise 
Authorization number. No packages will be accepted without the RMA number clearly 
marked on the outside of the package. After inspecting and testing, we will return your 
product, or its replacement using the same shipping method used to ship the product 
to A-WIT within 30 days. In your package, please include a daytime telephone number 
and a brief explanation of the problem. 

Please contact our Sales Department at sales@a-wit.com if you have any questions 
regarding our warranty policy or if you are requesting an RMA number.
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